Hi all!

Sorry, I have a lot of questions these days.

Here is the next one, which is really simple:

I cannot select neither annual glare nor timelapse.

Is this because of my Diva version, or my students license, or is something else wrong?

Best regards

Pascal

Tags: annual, glare, timelapse

Views: 978

Reply to This

Replies to This Discussion

Hello Yann,

Did the North model work with the annual glare simulation? If this is your first annual glare simulation, I have observed that gen_dgp_profile (the annual glare simulation management program) sometimes requires higher or special permissions compared to others, though I have not been able to explain why yet. Anyways, making sure that C:\DIVA\ has full permissions for all users and that c:\DIVA\DaysimBinaries\gen_dgp_profile.exe has the same is probably prudent.

Best,

Alstan

I will try as soon as i can to give gen_dgp_profile the autorizations (need to contact the IT crowd)
The thing really weird for me is that the north model already worked with the annual glare simulation. If i start with it, it works. I can do it right now! But if i make a rotation, save it with another name, set it up from the beginning again, it crash, whereas the others metrics work perfectly.

I'll let you know if setting the DIVA folder with full permissions fix it.

Best,

Yann

Hello,

I give full permission to the C:\DIVA folders, and first it was sometimes working and sometimes not.

In fact i found that some of my models were created with the 64 bit version and others with the 32 bit. The one who works with annual glare is the 32 bit version. I also think the permission was not necessary for my problem, but now i'm sure i can run annual glare and timelapse.

Thank you for you help, and have a nice day ;)

Hello,
I'm here again because of the annual glare simulations.

I'm expericencing some problems when running an annual glare.

Firstly, with the model attached in this post, i have a DGP under 35 everytimes if i set the view to 'VUEFOND' (the one annoted with 2). Even if the radiance bounce parameters is set to 7 instead of 2.

It can be true, but seems strange to me. And this view is always without glare whatever the orientation.

Secondly, When i'm running the annual glare with the other view (called 'VUEFENETRE' in rhino, the number one here), at the end of the calculation, DIVA shows me some VBS Script error (line 11) and doesn't create the map pictures netiher the HTML report.
A 'dgpread' file is created with the 'dgp' file, and contains exactly the same figures, with no text. And it shows the hole year calculation.

I don't understand what's going wrong, i tried to add a "pause" line into the img.bat file, but it doesn't add any clue

Don't understand what's going wrong. If it can helps you to help me, i attached my rhino file, the .epw i used and the dgpreadfile i had.

Best Regards
Yann

Attachments:

Hello Yann,

I still think your annual DGP problem must be due to permissions, because the simulation finishes, but it seems DIVA has a problem when processing the .dgp file. It is possible to manually generate the visualization. Here is some information I have shared with others before that might be helpful to you,

You can at the very least run the visualization step yourself by doing the following,
1. Replace all double-spaces in file.dgpread with single spaces using find and replace, and save the file.
2. Run the command,
c:\DIVA\Python27\python.exe c:\DIVA\Scripts\dgp_falsecolor.py c:\DIVA\Temp\file\file.dgpread c:\DIVA\Temp\file\file_imageprefix view1, not-adaptive

If you ran two views for your DGP calculation, the command would include view1,view2 as a comma-separated list. This will create the file c:\DIVA\Temp\file\file_imageprefixview1.png.

Out of curiosity, are you running the latest version of DIVA, 2.1.1.1?

In the case of your second view, it is around 7 meters from the window, so maybe it is not so strange? If the image is rendering correctly, it might be best to read up on the DGP metric and perhaps contact the authors.

All the best,

Alstan

Hi, Alstan,

After some time trying to fix it, we found out that the problem, in our case, was the python version. It seems that the version we had was incompatible with windows 7.

Best regards,

Ticiana



J. Alstan Jakubiec said:

Hello Ticiana,

In Pascal's case it did end up being a permissions issue where some programs were not being allowed to do what they needed to do. By giving full control to the 'Users' group for all of C:\DIVA\ this should fix the issue.

For Pascal there was an additional issue where he had to run Rhino as an administrator.

Hope that is helpful,

Alstan

Reply to Discussion

RSS

© 2019   Created by jeff niemasz.   Powered by

Badges  |  Report an Issue  |  Terms of Service