I upgraded my DIVA installation recently, and right away noticed an issue with the Archsim libraries in Grasshopper. When I launch the Archsim library component, instead of seeing the dialogue box I get the window (attached) and can't get any further with the library.

All of my old grasshopper energy models now get an output error in the E+ component that says "1. Solution exception:Object reference not set to an instance of an object" and the simulation won't start.

There error seems to be associated with the library component, because if I copy the old Archsim component assembly from my previous installation (ArchsimGH.gha) and swap it for the new component assembly in the ...DIVA\64bitPluginFiles\ArchSim directory, the library opens again. I do get an error from the library component, but if I create a new simulation from scratch (all new components) I don't get the E+ error and I can run simulations.

However, if I try to do anything with the library -- such as import my previous libraries -- the E+ error returns and simulations won't run. My existing files that all worked fine a few months ago are also coming up with errors. Just in case, I've attached an exported library that I was using last spring: RTZlibrary.json

I'm using a recently updated Rhino 5 64-bit and a recently updated Grasshopper. I've been using older simulation files and libraries for years after DIVA 4 came out, and never had any issues like this after updates. 

Maybe an installation bug? Thoughts?

I'll be introducing this software to a large group of students soon and I want to make sure everything is working smoothly.

Views: 748

Reply to This

Replies to This Discussion

Hi Rauland, the Server Busy warnings are different and not related to Archsim/DIVA.

I suspect a bug in R6/Rhino common cause those. Some users including myself were able to get rid of them by Turing off Automatic updates in Rhino.


I am getting the same error. In addition, any parameters I manually input in the Zone Settings Window will not save even is saved as a template. We're on Rhino 6

I need help What should I do?

Hi this looks like you are having issues with a dll not loading correctly. Most likely your ArchsimLib.dll is blocked or you have a duplicate dll somewhere. This causes only a partial set of components to show.

Thank you very much! ! The problem has been solved! !

Hi Michael, Is the problem you are discussing already solved?

Reply to Discussion


© 2019   Created by jeff niemasz.   Powered by

Badges  |  Report an Issue  |  Terms of Service