Dearest DIVA developers,

Thank you for your tireless work on constructing such an intuitive, fast, and reliable tool to make daylight analysis accessible to a wide range of designers and researchers. 

My question is in regards to the DIVA 4.1 update. A colleague of mine noticed that the DIVA command window states that it is running a DIVA 4.0 version and upon inspecting the properties of the DIVA.exe file, it appears to reference an old version. As of writing this, my DIVA Update Checker reads:

# DIVA-Update-Checker log file
# Last run time: 2018-12-19T09:40:52

DIVA is up to date.

So I am fairly certain that I am operating on DIVA 4.1. Hovering over a DIVA component in Grasshopper shows that it is referencing DIVA 4.1 too. (See attachments)

So, can you please let me know if I should be concerned? My colleague is finding his simulation times to take longer than usual. After troubleshooting other factors (simulation points, geometry, Radiance Parameters, etc), I am wondering if there is an inconsistency with DIVA versions that may cause some simulation lag. I doesnt seem logical but thought I would throw that out there for consideration.

Thanks!

Views: 196

Reply to This

Replies to This Discussion

Failing to upload images as an attachment. See screenshots below:

Dear DIVA developers,

Here's another screenshot of the issue we found on another workstation running DIVA 4.1. This time, we uninstalled all versions of DIVA before installing DIVAforRhino-4.1.0.8-x64-networked. There appear to be two issues that may relate to the long simulation times. One is the version conflict mentioned in the post above. The other is that we routinely get "Server Busy" pop-up messages which temporarily halt execution of the command line script after each completed step. This affects both the Annual Daylight and Glare Gh simulation components (which are the only ones we have tested thus far). What this means is that we have to repeatedly set focus on the cmd window shown below and hit 'Enter' to resume execution.

As a fallback, we attempted uninstalling DIVA and reinstalling DIVAforRhino-4.0.2.15-x64-networked. Unfortunately, this rendered all of the Gh simulation components non-functional, displaying a warning that the component was expired and failing to trigger the command line executable.

Any thoughts as to how we can resolve this?

Many thanks,

Ryan Welch

KieranTimberlake

Hi Kit & Ryan,

Sorry for the lag in response.  The version numbers are not a cause for concern.  We incremented the Rhino plugin and Grasshopper assembly versions to 4.1 to indicate R6 compatibility.  The backend executable (diva.exe) hasn't changed, and is fully compatible with both the R5 and R6 plugins.

As for the Servery Busy warnings, this is a known issue with R6.  I was under the impression that McNeel had resolved it (see this issue) ... has updating to the latest R6 release not fixed it?

Jon

Thanks for the reply, Jon. 

I am running Rhino Version 6 SR11 (6.11.18348.17061, 12/14/2018) and I am still having the Server Busy message. 

Yeah, I just managed to reproduce this on my end for the first time.  I pinged McNeel about it:

https://discourse.mcneel.com/t/how-to-suppress-server-busy-warning-...

In theory the simulation should finish properly if you ignore the warning window, but you won't be able to run a slider, etc.

I'll let you know when we have a solution.

Seems the Server Busy fix didn't make it in until SR12.  It's not on the website but you can get at it this way:

https://discourse.mcneel.com/t/rhino-6-for-windows-service-release-...

Did the trick for me ... let me know if it solves it on your end.

Hi Jon,

The update to SR12 worked for me but DIVA still feels sluggish. Opening a previous DIVA file took a few minutes which hasnt happened before. 

Kit

Reply to Discussion

RSS

© 2019   Created by jeff niemasz.   Powered by

Badges  |  Report an Issue  |  Terms of Service