Have been using Diva for a while, great program, but never seen this before, has anyone else?  Is there a fix?  Can't seem to get results for this particular building, only this error.  Tried rebuilding the model from scratch, still happened. 

Error loading image:

Traceback (most recent call last):

File "C;\Dokumente und Einstellungen\Administrator\Desktop\pyray\utils\build\pyi.win32\wxfalsecolor\outPYZ1.pyz/falsecolor2", line 922, in readImageData

File "C;\Dokumente und Einstellungen\Administrator\Desktop\pyray\utils\build\pyi.win32\wxfalsecolor\outPYZ1.pyz/falsecolor2", line 953, in _analyzeImage IndexError: list index out of range

Thanks

Dan

Views: 2118

Reply to This

Replies to This Discussion

Hi Daniel,

 

This error is a little misleading because it is a wxFalsecolor error caused by a visualization simulation crashing. Basically, the simulation crashes, creating an empty Radiance file. Then wxFalsecolor presents this error while trying to open the empty file.

 

A useful, though cryptic, way to diagnose the cause of the error is to do the steps I list below. If you don't feel comfortable following these, you can email a zip of  your entire  C:\DIVA\Temp\RhinoFileName\ folder to me at alstan@jakubiec.net.

 

Best,

Alstan 

 

1.  Browse to C:\DIVA\Temp\RhinoFileName\ and open the RhinoFileNameimg.bat file with a text editor.

2. Add the text "PAUSE" to the final line of this file, and save it.

 3. After saving and closing the file, double click it. The Radiance simulation will run, but you will get to see any errors that occur before it closes.

 

 

I actually got the same error just now, I've gone through the procedures you outlined and below is what I get :

 

 

I thought it would be the obj export options so I change them to :

but that still didnt work (by the way - are they set right..? )

 

So I typed in pause in the file and re-ran and got this:

 

 

 

Same text here:

 

 


C:\DIVA\Temp\Mayfield03>SET RAYPATH=.;C:\Radiance\lib

C:\DIVA\Temp\Mayfield03>PATH=C:\Radiance\bin;$PATH

C:\DIVA\Temp\Mayfield03>c:

C:\DIVA\Temp\Mayfield03>cd C:\DIVA\temp\Mayfield03

C:\DIVA\Temp\Mayfield03>oconv Mayfield03material.rad Mayfield03_sky.rad Mayfield
03.rad  1>Mayfield03.oct
oconv: warning - (Mayfield03.rad): empty file

C:\DIVA\Temp\Mayfield03>rpict -t 15 -vtl -vp 1423.254 1337.866 444.172 -vd 0 0 -
444.172 -vu 0 0 1 -vh 226 -vv 147 -vs 0 -vl 0 -af Mayfield03.amb -x 1600 -y 1200
 -dp 128 -ar 23 -ds 0 -dt .2 -dc .25 -dr 0 -st .5 -ab 2 -aa .25 -ad 1024 -as 16
-av 0.01 0.01 0.01 -lr 6 -lw .01 -ps 8 -pt .16 Mayfield03.oct  1>Mayfield03_Top.
unf
rpict: fatal - view up parallel to view direction
rpict: 0 rays, 0.00% after 0.0000 hours

C:\DIVA\Temp\Mayfield03>pfilt -r .6 -x /2 -y /2 Mayfield03_Top.unf   1>Mayfield0
3_Top.pic
pfilt: bad picture size

C:\DIVA\Temp\Mayfield03>del Mayfield03_Top.unf

C:\DIVA\Temp\Mayfield03>ra_tiff Mayfield03_Top.pic Mayfield03_Top.tif
ra_tiff: bad Radiance picture

C:\DIVA\Temp\Mayfield03>del Mayfield03.amb
Could Not Find C:\DIVA\Temp\Mayfield03\Mayfield03.amb

C:\DIVA\Temp\Mayfield03>PAUSE
Press any key to continue . . .

 

 

 

 

 

 

You are using Rhino 5, I assume? In your object export settings it should be set to as OBJ "o" I think. 

 

Alstan 

Changing the view to a fish eye and selecting "saved views only" for camera views, I get an image - with no building -

I check DOS and there is this near the top : (Mayfield.03.rad): empty file

 

I'm using the US version of Rhino 4.0 SR9, educational ... not an eval..

Oh, I misunderstood the situation. Can you send me the Rhino file? Two things are apparent from your screenshots. 

  1. Something is happening with the geometry being exported.
  2. You are running the simulation in a projected (elevation, plan) rather than perspective viewport.

Thanks,

Alstan 

Your model works out of the box for me. I did run the "SelBlockInstance" command a few times, and exploded the results first. I include a screenshot of my export options below as well.

 

If stuff keeps going bad, you can zip your entire C:\DIVA\Temp\RhinoFileName\ directory and send it to me. 

 

Alstan 

 

 

 


It worked for me once I did what you said - selblockinstance and then explode them,

I also changed my obj export plugin back to the original file, not the upated one and set the options you show above

 

then it wasn't liking my choice of the standard translucent glazing.. no clue why .. so I change it to somthing else  in my materials and reran, finally got somthing out'a it.. now I'll start refining..

 

Any idea why it wouldn't like (be able to find) the translucent material? I check the .rad file in the temp directory and it was written to it..

 

Ah yes, that is a bug with DIVA-1.9.

 

There is an error in our batch files preventing the location of the cal and dat files for the Generic Translucent material. To fix it in 1.9, copy two files from C:\DAYSIM\lib\ to C:\Radiance\lib\

  1. rang.cal 
  2. GenericTranslucent20.dat. 

This is fixed in DIVA-2.0.

 

Best,

Alstan 

 Thanksf or that fix!

 

You know what the main cause is for images with interiors that are dark, as below?

My AB (ambient bounce) is set to 4 in this run

each window is one polygon - windows are not "doubled  up.."  I tried deleting one and I could see the interior of the building.. materials are selected correctly..

I didnt get any errors in the run..

 

So if you run a visualization without deleting the windows, you cannot see into the building? It does sounds like there is somehow a materials-setting issue at hand.

 

Alstan 

It was an issue with increasing the bounces and adjusting my range.. I interpreted the lux/fc settings under illuminance values - I had entered lux values into my range when I had the FC box selected.. . 

That would certainly do it. Unfortunately I could just barely not see your units in the screenshot! Thanks for letting us know the results.

Reply to Discussion

RSS

© 2018   Created by jeff niemasz.   Powered by

Badges  |  Report an Issue  |  Terms of Service