I followed the installation instructions. and when i want to create nodes on a surface. I get this error  (see image)

Source : Microsoft VBScript runtime error

Error :Type mismatch : 'Unbound'

Line : 297

Char : 1

Code :

Is there something wrong.

I'm runing rhino 5 64 bit on windows 8

Views: 3743

Reply to This

Replies to This Discussion

Hi Claudio,

How wide is that geometry? I suspect that a smaller node distance may help you in this case. If your input is too large relative to the geometry, no nodes are created and results in a crash.


Hi alstan

The plane is 7m by 10m. I've also though that the sample points where to large. But I tryied with the defautl ones and I get the same result.

Now when I do it in rhino 4 it seams to work. But when diva try to import the data into rhino I get the same crash. Maybe it has something to do with the installation in Rhino 5.

I'm testing DIVA sine version 1 And now that I get my office to buy it it does not work properly with rhino 5. I have the latest update for rhino...

Hi Claudio,

I'm sorry for the problems. This will sound like a weird question, but is your Rhino version English? I'm bringing in my Rhino 5 install cd tomorrow so I can test other localizations of Rhino.

Also, would you mind posting the Rhino file you are using?

edit: I updated Rhino 5 to the Jan. 29, 2013 SR version. Suddenly I have the same error as you do. I will dig into what changed with this service release to cripple DIVA.

Thanks a lot,


LEt me know when you have something

thank you

Hi Claudio,

I got confirmation from McNeel that there are some problems with Rhinoscript in their Jan. 29 release. The gentleman I'm speaking with suggested that the next version will not have this problem.



Hi Alstan & Claudio,

Has anyone had any luck with this error?  I am still getting the Type Mismatch 'Unbound' error.



Hi Taryn,

As of now, I think the only way to solve the issue is to uninstall Rhino 5, reinstall it from the CD, and disable automatic updates. I wrote a warning blog post at the top of our front page by now, but that doesn't help your immediate problem. I have it on good authority from McNeel that Rhino 5 SR2 will not include this problem.

Alternatively, Rhino 4 does not share this problem, if you also have it installed.



Hi Alstan, 

I'm getting the same VBscript error type mismatch 'Unbound' but on Rhino 5.0 trial versions (some students that are getting into DIVA) which dates from:

Version 5 (5.1.30103.145, 1/3/2013)

It's a previous version that the one you mention in the blog. Is it the same problem? If so, can I fix it?


Luís dos Santos

Hi all,

We just released an update to work around the problem. You can find out about it in this blog post update.

Thank you,


Reply to Discussion


© 2020   Created by jeff niemasz.   Powered by

Badges  |  Report an Issue  |  Terms of Service