Hi all,

I just started using Diva for Grasshopper but unable to get the results to show properly. I'v tried a few ways but none of them worked. Could anybody help me out? (sorry for the long post..I figure it might be helpful to post all of them in case someone else in future has similar problem)

 

Grasshopper version:0.9.0064

DIVA version:2.0.0.7

Rhino verson:0.9.0064

test01.3dm

test01.gh

test02.gh

test03.gh

11-surface%20construction.gh

 

Test 01.3dm + Test 01.gh or Test 03.gh

Using grasshopper grid, no error but the result won't show on Rhino screen

 

Test01.3dm + Test02.gh

Error shown on ConMesh:"Solution exception:Object reference not set to an instance of an object"

 

 

11-surface construction.gh

the result is upside down(visible from the bottom view instead of top view)

 

 

 

Thanks very much!

 

Views: 427

Attachments:

Reply to This

Replies to This Discussion

Hi,

In case 1, you have the move component preview, the original grid component preview and your results preview all coincident. Disabling the first two will solve the problem. The 11-surface construction file seems to have the same problem.

When you try to build your results as a Mesh (case 2), the colors are assigned to each vertex. So its best to use the surface vertices as your input nodes. See my attached file.

Best,

Alstan

Attachments:

Thanks Alstan. The results are showing now. However when I was comparing Test01.gh and Test02.gh results, they looked quite different:

Test01 Result

 

Test02 Result

Both have 8x8 grid, Test01 looks about right, not sure what happened to Test02 nodes and why it rendered so differently.

 

Thanks!

Attachments:

Test 2 has the sensor locations placed at the red X's, but Test 1 has them placed at the center points of each mesh cell. So that explains the discrepancy.

Best,

Alstan

Thanks Alstan! I thought the nodes were messed up on Test02 since it looked as if the light was bleeding through the left edge. I scaled the mesh down and it works fine now.

Again thanks for your help!

Wei

Reply to Discussion

RSS

© 2018   Created by jeff niemasz.   Powered by

Badges  |  Report an Issue  |  Terms of Service