when I use the Sunpath component, I don't see the shadows on the ground plane. Can somebody point the error please?


Views: 974


Reply to This

Replies to This Discussion

There are a couple possible reasons for this.  My first question would be, do shadows ever work for you in Rhino?  (I.e., do you see them in Rendered display mode, as below?)  If not, you might want to refer to this post on supported graphics cards: https://discourse.mcneel.com/t/render-displays-no-shadow/8704.

If you do see these shadows, I'd recommend the following to repair the sun path tool:

1) Delete your current DivaSunPath display mode entirely:
Inline image 1
2) Close Rhino.
3) Delete the file C:\DIVA\Scripts\DivaSunPath.ini.
4) Make sure you have the latest version of DIVA. (While connected to the internet, double click the DIVA-Update-Checker executable in C:\DIVA\bin.  If an update notification pops up in your system tray, run it).
5) Reopen Rhino + GH, and try the Sun Path component again.  (The display mode will get recreated from an embedded resource.)
Hi Jon,
I have a few students experiencing a similar problem. One I diagnosed as a Parallels issue (virtual machine not making proper use of graphics card). I have another student who is running a PC whose "rendered" view successfully casts shadows and who has tried to delete and reset the Sun Path component per your instructions, but the sun path component still fails to create shadows. Do you have any other ideas about what might be causing the problem? Thanks!

Not sure if it's relevant, but the current renderer should be Rhino Render.  If it's something else (Vray, etc.), I believe the shadows won't work.  Because the sun path tool relies on Rhino Render, the settings also matter:

Changes to the environment (e.g. turning on skylight) can make the shadows disappear.

If these aren't the issue, maybe I can take a look over video chat.


Hi Jon,

I am having the same issue and I have tried all the recommendations mentioned above, but nothing seems to work, when I place the Sun Path in Grasshopper, everything in Rhino turns wireframe without generating shadows. Do You have any other recommendation?

Thank You

Hi Jon,

I am having the same issue. It worked fine a month ago, now there are no shadows anymore and nothing changed regarding graphics card. Also tried all the recommendations but without success. The image shows how it looks like for me.

I am thinking about reinstalling diva. Could this work?

Thank you,



Reply to Discussion


© 2017   Created by jeff niemasz.   Powered by

Badges  |  Report an Issue  |  Terms of Service