I get this error when I try to run the simulation:

1. Write failed.
12 manual shades
0 auto shades
0 custom shades
manual sensor ray count = 532
The pipe has been ended.

Any ideas?

Views: 267

Reply to This

Replies to This Discussion

Update.... I switched the model units to millimeters vs inches and it worked. There may be some default setting in the window component that does not jive well with inches as units.

Hmm, that's odd.  I think most times a thread ends abruptly like that, DIVA's not catching a Radiance error.  Not sure what that could be in this case.

BTW, If you change file units without replacing the component, I don't think the input values change -- so you may be left with default inputs that are not very sensible...


After experiencing the issue, I manually changed the input values but still no luck. 

It is a really simple model so I can't imagine any geometry problems... worse case scenario I can run in mm, but if we can find a solution so I can keep it in inches, that would probably avoid some scaling headaches on this end.

Happy to send you my files.

It definitely seems to be something with the sensors. Switching the units kept the defaults so there were actually no sensors on the grid. Runs without the sensors, does not run with the sensors. 

Feel free to post an example... make sure to include your material file.

Thanks, emailed you the files.

Hi Elliot,

not sure where you are placed, but I resolved a similair error by changing my windows decimal seperator to a dot "." as here in Denmark the regular decimal seperator is a comma "," .... and then restart computer.

(regional settings -> advanced -> numbers and formatting )

However this causes me trouble in a lot of other programs when all formatting is changed, ugh!

Thanks, Mathias. I am based in the US, so that turned out to not be issue. With Jon's help, I was able to identify the error was in the way I was parametrically defining the Radiance materials... I was forgetting to specify the specularity and roughness of the opaque materials. I had defined:

void plastic Wall
5 0.7 0.7 0.7
and it should have been:
void plastic Wall
5 0.7 0.7 0.7 0 0

It was a bit of a red herring that the error message called out the windows and that it was running without the sensors because that led me to think the error was related to that. Its weird because the simulation should have failed in all cases so we couldn't explain why it was running with no sensors, but at least we found the issue and I am up and running with my simulations! 

Reply to Discussion


© 2020   Created by jeff niemasz.   Powered by

Badges  |  Report an Issue  |  Terms of Service